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Preface 
EstuaryDB  is a MatlabTM App that enables tables of estuary data (multi-estuary) to be loaded. In 

addition, estuary specific datasets that are vector or matrix can also be loaded, such as along-channel 

data, bathymetry and images. Several be-spoke plotting functions are included to examine the 

variation amongst estuaries, including cross-plots to examine variations about central values (e.g., 

HW, MT, LW). 

Requirements 
The application is written in MatlabTM and provided as Open Source code (issued under a GNU 

General Public License) and runs under v2016b or later. EstuaryDB uses the muitoolbox and 

dstoolbox, both available from https://github.com/CoastalSEA. 

To read linework that has been saved as shape files, EstuaryDB includes options to use the Matlab™ 

Mapping Toolbox, or the function m_shaperead.m, that is part of the M_Map1.4 package 

(https://www-old.eoas.ubc.ca/~rich/map.html), needs to be installed. In addition, there is the option to 

use the function insidepoly as an alternative to the Matlab™ function inpolygon (see 

https://uk.mathworks.com/matlabcentral/fileexchange/27840-2d-polygon-interior-detection). 

 

Resources 
The EstuaryDB App and two toolboxes (muitoolbox and dstoolbox) can be downloaded from 

https://github.com/CoastalSEA..  

Cite as: 

Townend, I.H., 2021, EstuaryDB  manual, CoastalSEA, UK, pp58, www.coastalsea.uk. 
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1 Introduction 
EstuaryDB  is a MatlabTM App that enables tables of estuary data (multi-estuary) to be loaded. In 

addition, estuary specific datasets that are vector or matrix can also be loaded, such as along-channel 

data, bathymetry and images. Several be-spoke plotting functions are included to examine the 

variation amongst estuaries, including cross-plots to examine variations about central values (e.g., 

HW, MT, LW). 

1.1 Origins of the UK Estuary Database 
The original work on UK estuaries was undertaken by Davidson et al (Davidson et al., 1991). Similar 

work on classification has been undertaken in other countries such as New Zealand (Hume and 

Herdendorf, 1988; Hume et al., 2007) and the United States of America (Hansen and Rattray, 1966; 

Pritchard, 1989; Geyer and MacCready, 2014). In the UK, the Estuary Research Programme that ran 

from 1998-2007. An early version was a byproduct of the EMPHASYS project and led to two papers 

that provided data and guidance (Townend, 2004; 2005). These concepts were then encapsulated in a 

portal published by Associated British Ports (ABP) and known as the Estuary Guide (www.estuary-

guide.net). Subsequent development of the portal was funded by the Department of Food, 

Environment and Rural Affairs (Defra), the Environment Agency (EA) and Natural England (NE). 

The portal has undergone updates over time funded through joint Defra / Environment Agency Flood 

and Coastal Erosion R&D Programme.  

There have been many contributors to this work, drawing on a wide range of experience. These 

include: ABPmer, HR Wallingford, Black & Veatch, British Geological Survey, CEFAS, Centre for 

Ecology and Hydrology, Halcrow, Plymouth Marine Laboratory, Posford Duvivier, Proudman 

Oceanographic Laboratory, Royal Holloway University of London, University College London, 

University of Cardiff, University of Durham, University of Liverpool, University of Newcastle, 

University of Nottingham, University of Plymouth, University of Southampton and WL|Delft 

Hydraulics Laboratory. 

One of the key limitations of this work is the quality of the data available in the early 2000’s to create 

detailed digital terrain models of the estuaries. Whilst a consistent approach was used to determine 

properties such as volumes and surface area, there were known errors based on comparisons with more 

detailed data sets (see Townend, 2005). With the advent of more detailed information for both estuary 

form but also tidal levels and river discharges, there is now an opportunity to revisit the large-scale, or 

gross, properties of estuarine systems. The tools provided in the EstuaryDB  aim to provide a 

consistent approach that can be adopted to investigate the morphology of estuary systems. 

1.2 The Estuary Project 
The EstuaryDB App has been developed to enable a more detailed investigation of estuary and tidal 

inlet hypsometry. It brings together the option to collate a range properties such as tides, river 

discharge, classifications, etc, with hypsometry data derived from a bathymetry grid and derived 

properties such as rates of convergence and gross properties. This can be used to investigate individual 

estuaries, or groups of estuaries. In the UK it is being used to update the data held in the UK Estuary 

Database. However, such data are necessarily limited by the range of type and settings to be found in 

the UK. To expand the scope of datasets available for further analysis (e.g. to explore equilibrium 

across a range of system types) the App includes the option to archive sets of results as ASCII files. 

These can also be imported into the App. To avoid data ownership issues the archive file does not 

include the grid used to create the hypsometry datasets, although the grid, or an image of the grid, can 

be archived alongside the archive file. This keeps the dataset to the minimum needed for further 

analysis, whilst providing details of how the datasets were derived and the ability to rerun the analysis 

by simply loading a suitable (or updated) bathymetry grid. [Add details of repository] 

  

http://www.abports.co.uk/
http://www.estuary-guide.net/
http://www.estuary-guide.net/
http://www.defra.gov.uk/
http://www.defra.gov.uk/
http://www.environment-agency.gov.uk/
http://www.natural-england.org.uk/
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2 Getting started 
2.1 Configuration 
EstuaryDB is installed as an App and requires muitoolbox and dstoolbox to be installed. The 

download for each of these includes the code, documentation and example files. The files required are:  

dstoolbox: dstoolbox.mltbx 

muitoolbox: muitoolbox.mltbx 

The App file: EstuaryDB.mlappinstall 

2.1.1 Installing the toolboxes 
The two toolboxes can be installed using the Add-Ons>Manage Add-Ons option on the Home tab of 

MatlabTM. Alternatively, right-click the mouse on the ‘mltbx’ files and select install. All the folder 

paths are initialised upon installation and the location of the code is also handled by Matlab™. The 

location of the code can be accessed using the options in the Manage Add-Ons UI. 

2.1.2 Installing the App 
The App is installed using the Install Apps button on the APPS tab in Matlab™. Alternatively, right-

click the mouse on the ‘mlappinstall’ file and select install. Again all the folder paths are initialised 

upon installation and the location of the code is handled by Matlab™. 

Once installed, the App can be run from the APPS tab. This sets the App environment paths after 

which the App can be run from the Command Window using: 

>> EstuaryDB; 

The App environment paths can be saved using the Set Path option on the Matlab™ Home tab. 

Documentation can be viewed from the App Help menu, or the Supplemental Software in the 

Matlab™ documentation. The location of the code can be accessed by hovering over the App icon and 

then finding the link in the pop-up window. 

 

2.2 Quick Guide 
File>New to create a new project space. 

Setup>Import Table Data>Load 

Load some data from an array in a text file, a worksheet of a spreadsheet, or an existing table or 

dstable from a .mat file (see Section 3.4 and Appendix A - Import file formats). The user is prompted 

for a file and then for a description of the data source (text string) and a name for the dataset (must be 

a valid MatlabTM variable name, or the code will try to convert the text entered to a valid name). 

When loaded into a dstable the data are assigned dsproperties (i.e., name, description, unit, label and 

qcflag or format – see Appendix B - Data set properties (DSproperties)). By default, these are assigned 

the variable name and qcflag is set to none. The user is then prompted to load a File of definitions 

(which can be an .m file, text file, or Excel file), or use a UI to input the definitions manually, or Skip 

this step and use the defaults. For details of how to set the DSproperties and import file formats see 

Section 3.4 and Appendix C – Sample DSproperties for data import). 

Setup>Import Table Data > Add to Table>Dataset: prompts for file to be added (only one file at a 

time can be added) and the Case to use (if more than one Case). For other options see Section 3.4. 

Individual tables can be viewed on the Table tab and simple default plots are accessed using the Q-

Plot tab. 

Analysis>Plots 

The imported data can be selected and plotted. By using the Add button, additional Cases, Datasets or 

Variables can be used to define a plot variable, allowing rapid intercomparison of datasets. 
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2.3 Typical Workflows 
Several different types of data can be loaded and analysed in the EstuaryDB App. This involves 

different workflows depending on the type of data being loaded. This may be loading an existing table 

of morphological properties for several estuaries (scalar data table), or loading or generating 

hypsometry data for surface area, S(z), or width, W(x,z). Details of how to access the various types of 

data are given in Section 3.10. 

2.3.1 Tabular Properties 
A simple table holds scalar values. For example, this may be the properties for a number of estuaries 

and can be in Excel, ASCII text or .mat matlab format. Some example files of this type of data are 

provided in the …/example folder. When loading from an Excel spreadsheet, the user is prompted to 

confirm the worksheet, rows and columns to load. For a text file the header is used to define the inputs 

(see Appendix A - Import file formats). The user is then prompted to load, define or skip the definition 

of the DSproperties. For a quick look at the data this can be skipped but for more detailed exploration 

the DSproperties are used extensively in EstuaryDB to provide meta-data about selections. If loading 

from a file, this can again be in Excel or ASCII text format and once loaded there is the opportunity to 

check and edit the meta-data for each variable. 

To complete the process the user is prompted for a Case description. The record can then be viewed on 

the Data tab and checked on the Q-Plot and Properties > Dataset tabs. 

 

2.3.2 Surface Area Hypsometry 
The surface area data can be loaded directly from a spreadsheet or text file (see 3.4.2, 4.1, and 

Appendix D – Bespoke data import format file). Alternatively, there are two options to create the data 

set within the App. For both cases load a bathymetry grid (see Section 3.4.2) and make any 

adjustments using the Grid tools (see Section 3.4.4). The either: 

(i) Load a shape file to define the enclosing waterbody boundary (see Section 3.4.5); or 

(ii) Use the Setup > Sections > Waterbody tool to define a suitable polygon boundary (see 

Section 3.4.5). 

Use the Tools>Hypsometry >Surface area to generate the new data set and add it to the estuary Case 

record (see Section 3.5.1). Upon execution a plot of the grid with the enclosing waterbody polygon are 

shown alongside the surface area and volume hypsometry. The volume hypsometry is not stored in the 

dataset but calculated when needed. The new dataset can then be viewed on the Q-Plot and Table > 

Dataset tabs. 

[NB: if using the function insidepoly which is much faster than the Matlab ™ function inpolygon, 

ensure there is a single boundary and no extraneous line work, as this can lead to “drop outs” in the 

selection of grid points within the bounding polygon.] 

 

2.3.3 Width Hypsometry 
The along-channel width hypsometry for a single reach can be loaded directly from a spreadsheet or 

text file  (see 3.4.2, 4.1, and Appendix D – Bespoke data import format file). Alternatively, the tools 

provided in the App can be used to define the sections and compute the hypsometry for estuaries with 

multiple reaches. Start by loading a bathymetry grid (see Section 3.4.2) and make any adjustments 

using the Grid tools (see Section 3.4.4). Then work through the Section tools to create the linework 

needed to extract cross-sections. The steps are as follows: 

(i) Create a boundary to the estuary using Setup > Sections > Boundary (see Section 3.4.5). 

This sets the extent of the cross-sections. The boundary should be set at an elevation that 

allows the hypsometry to be computed over the desired range of elevations. However, it 

does not need to be accurate or detailed because the boundary is only used to adjust the 
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length of the sections. The interface allows the generated contour to be smoothed or 

resampled. The latter should be done to minimise the size of the line and make editing 

simpler. 

(ii) Create a centre-line for the channel(s) using Setup>Sections>Channel Network (see 

Section 3.4.5). If there are multiple channels there may be a need to create several lines. 

Again, precision is not required, as long as the lines follow the channel. The interface 

allows the generated centre-lines to be smoothed or resampled. The latter is done as the 

line is created, based on the interval defined when the option is opened but can be adjusted 

within the interface. The points in the centre-line are used to position the section lines. 

Consequently, the sampling interval determines the section line interval. However, there is 

also a need to avoid sections crossing one another. In particular, no section should cross 

more than one centre-line. This can be adjusted in step (iii) but is helped by starting the 

centre-line for channel branches within the branch rather than close to the channel that it 

joins. 

(iii) Once the Boundary and Centre-line have been defined the section lines can be created 

using Setup>Sections>Section Lines  (see Section 3.4.5). The section length determines 

the distance of the section line end points either side of the centre-line and sections are 

generated at every point on the centre-line. The interface provides options to clip the 

section lines to the boundary of the channels and edit the lines. At this stage it is important 

to ensure that there is a centre-line point on every section line, that crossing section lines 

are edited or deleted and to make sure that no section line crosses more than one 

centre-line.  

(iv) The completed section lines can then be used to generate the cross-section Setup> 

Sections>Section (see Section 3.4.5). A composite plot of all the sections is generated 

upon completion and the y, z data saved. 

(v) The final preparatory step is to define the channel connectivity using Setup>Sections> 

Channel Links (see Section 3.4.5). Follow the in-figure instructions to select branches the 

channel point that they connect to. The interface will allow selection of branches and 

nodes to continue until all branches have been linked into the network. A summary graph 

of the network topology is plotted and this shows the index of the connecting points the 

line numbers and the distances from the first point (usually the mouth of the estuary). 

The along-channel width hypsometry can now be added using Tools>Hypsometry >Width to generate 

the new data set and add it to the estuary Case record (see Section 3.5.1). Upon execution a plot of the 

width hypsometry for all reaches combined and a composite plot showing the contribution of 

individual reaches are generated. The new dataset can then be viewed on the Q-Plot and Table > 

Dataset tabs. 

 

2.3.4 Gross Properties 
Once a hypsometry has been created using either the surface area or the width options, the gross 

properties can be computed and added to the Gross Properties table (see Section 3.4.3). The results can 

be viewed on the Table > Morphology tab. 

 

2.3.5 Illustrated Workflow 
The above steps are illustrated with a case study based on the Colne Estuary in the UK. 
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(i) Surface Area Hypsometry 

Setup > Waterbody > Generate                 Extract 

contour at 3 mAD (red lines) 

Resampled at 100m, superfluous lines deleted 

and boundaries closed to form a polygon 

  

 

To create the table of surface area hypsometry use: Tools >Hypsometry > Surface Area. NB: the 

upper level for the hypsometry must be above the highest level required for subsequent analysis (e.g 

HAT+slr).  

The results can be viewed on the Q-Plot tab.  

To add the Gross Properties to the Morphology table, first add the tidal levels using Setup>Estuary 

Properties>Tidal Levels and then add the gross properties using Tools>Gross Properties>Add.  

The results can be viewed on the Properties> Morphology tab. 
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(ii) Width Hypsometry 

Setup>Sections>Boundary>Generate Copy line work for Waterbody 

Setup>Sections>Channel Network>Generate  

Set first line for main channel. Smooth the line 

(default settings used) – aim to minimise the 

curvature, as this will reduce the number of 

intersecting cross-sections. Edit any kinks at the 

end of lines. 

Try to get the first 2-3 points of the first line at 

right angles and approximately straight to the 

section that will define the mouth section (e.g. 

Extend line with a new start point and then 

Resample). 

 

Centre-lines should start at the seaward end and 

be drawn in a landward direction. The first line 

should start at the mouth, the first point being 

used to define the mouth section. The order of 

branches is not critical but it makes the plots 

clearer if they are approximately ordered based 

on distance from the mouth. 

 

Setup>Sections>Section Lines>Generate         

Set the initial cross-sections for the main channel 

using a length of 3000 m. 

 

 

Cip the lines to limit their extent where they 

cross the boundary. 

 

 

 

Assess which areas need infilling 
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Setup>Sections>Channel Network>Generate  

Modify the existing linework. Add additional 

centre-lines to provide additional lines. This can 

be a mix of Set lines and Add lines (2 or more 

points to create additional lines). Smooth and 

Resample to create set of points that will 

complete the section coverage of the estuary 

basin . 

Setup>Sections>Section Lines>Generate        

Reset  to remove any existing linework and then 

Set the sections (a length of 3200 m used to 

ensure coverage of the  tidal flats). The centre-

line point filled in white is the first point in the 

data set. Sections are only created for points 

above the point selected and the centre-line 

points are adjusted to match. 

 

Note that the branch centre-lines are to represent 

the basin not the meandering channels and do 

not need to extend to the main channel. 

 

 

Once the sections lines have been Clipped to the 

boundary the coverage is clearer. The process of 

defining centre-line points and determining the 

section coverage that they provide is often an 

iterative process, especially if there are a number 

of branches and large intertidal areas. 

 

Once a reasonable coverage has been obtained 

without too many section line crossings, the 

linework can be edited to give the final section 

line definition. A composite plot of boundary, 

centre-lines and sections lines can be viewed 

using Setup> Sections>View Sections>Layout. 

  

NB Adding section lines forces a Reset of the section lines. It is therefore best to make any 

additions and deletions before undertaking any detailed editing of overlapping sections. 
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Setup>Sections >Sections 

Generates and saves a set of cross-section using 

the defined section lines. NB: the upper level for 

the sections should be above the highest level 

required for subsequent analysis (e.g HAT+slr). 

In the plot, click on any line to get the section 

number. Use the figure editing tools to remove 

unwanted sections. 

This graph can be recreated using 

Setup>Sections>View Sections>Sections 

 

Setup>Sections >Channel Links                 

Check that there is only one point (circle marker) 

on every section (red line). 

 

 

 

Select branch lines (in any order) and then define 

the point that the branch connets to. The line 

numbers turn orange one assigned and the 

window closes once all connections have been 

defined. 

 

A graph plot is generated which shows the 

centre-line points at which there are joins and 

the distance from the first point in paranthesis. 

The centre-line line number is shown on each 

edge. A value of 0 indicates a join. This graph 

can be recreated using Setup>Sections>View 

Sections>Network 
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This completes the steps needed to be able to 

create a table of width hypsomtery.  

To create the table of width hypsometry use: 

Tools >Hypsometry > Width. NB: the upper 

level for the hypsometry must be above the 

highest level required for subsequent analysis 

(e.g HAT+slr).  

The results can be viewed on the Q-Plot tab. 

 

To add the Gross Properties to the Morphology 

table, first check that the tidal levels have been 

loaded on the Table > Tides tab, or add them 

using Setup>Estuary Properties>Tidal Levels. 

The gross properties can then be added using 

Tools>Gross Properties>Add and selecting the 

Width data set.  

The results can be viewed on the Properties > 

Morphology tab. 

 

 

 

(iii) Additional tips 

Smoothing Channel Centre-lines. An option to improve the quality of the centre-line for the generation 

of sections is to smooth the line so that it has minimum curvature (even if it no longer follows the 

centre of the channel). To remove a sharp bend, use the edit line tools to: 

• Split the centreline some distance on either sider of the of points to be corrected; 

• Delete the line between the two split points; 

• Join the split lines; 

• Resample the lines to add points at the desired interval. 

Alternatively: 

• Delete points that are causing sharp bends, resample and smooth. 
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(iv) Further analysis 

Datasets, such as tabular properties, grids, surface area and width hypsometry can be used in the 

various EstuaryDB tools. These include plotting (Section 3.6.1), statistical analysis (Section 3.6.2) and 

deriving new variables from the data (Section 3.5.3).  There are also some customised options to plot 

and analyse the data, which include: 

• Tools> User Tools – show table and add bespoke analyses (e.g. to derive new variables and 

add to existing table or a new one), see Section 3.5.4; 

• Analysis > Tabular Plots - bespoke plots for scalar tabular data, see Section 3.6.3; 

• Analysis > Hypsometry Plots - bespoke plots for the surface area and width hypsometry data 

sets, see Section 3.6.3; 

• Analysis > User Plots: calls function ‘edb_user_plots.m’, allowing additional plots to be 

added as required. 

See Section 3.6.3 for some example plots.  

Where there are branches, or multiple 

islands, additional internal “boundaries” 

can be added to improve the ability of 

the Clip tool to create section lines 

within defined zones. In this example 

for Poole Harbour, the side channels 

were closed off with boundary lines and 

the islands were joined to define the two 

main branches. A small barrier line was 

added to the east of the mouth. With 

these additions and careful smoothing of 

the centrelines, almost no editing was 

required once the section lines had been 

set and clipped. 
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3 Application Menus 
 

The UI comprises a series of drop down menus that provide access to a number of commonly used 

functions such as file handling, management of run scenarios, model setup, running and plotting of the 

results. In addition, Tabs are used to display set-up information of the Cases that have been run. In this 

manual text in Red italic refers to drop down menus and text in Green italic refers to Tab titles. 

 

3.1 File 
File>New: clears any existing model (prompting to save if not already saved) and a popup dialog box 

prompts for Project name and Date (default is current date).  

File>Open: existing models are saved as *.mat files. User selects a model from dialog box. 

File>Save: save a file that has already been saved. 

File>Save as: save a file with a new or different name. 

File>Exit: exit the program. The close window button has the same effect. 

 

3.2 Clear 
Clear>Refresh: updates Cases tab. 

Clear>Clear all>Project: deletes the current project, including setup parameters and all Cases. 

Clear>Clear all>Figures: deletes all results plot figures (useful if a large number of plots have been 

produced). 

Clear>Clear all>Cases: deletes all cases listed on the  Cases tab but does not affect the model setup. 

 

3.3 Project 
Project>Project Info: edit the Project name and Date. 

Project>Cases>Edit Description: select a scenario description to edit. 

Project>Cases>Edit DS properties: edit the properties that define the meta-data for a dataset. 

Project>Cases>Edit Data Set: edit a data set. Initialises a data selection UI to define the record to be 

edited and then lists the variable in a table so that values can be edited. The user can also limit the data 

set retrieved based on the variable range and the independent variable (X) or time. This can be useful 

in making specific edits (eg all values over a threshold or values within a date range). Using the Copy 

to Clipboard button also provides a quick way of exporting selected data. 

Project>Cases>Modify Variable Type:  select a variable and modify the data type of that variable. 

Used mainly to make data categorical or ordinal. First select a variable then the data type required. For 

text data the next UI lists the categories found for the selected data set. The first input can be modified 

to the required order. The second input can either match the first, or define alternative category names 

in the order defined for the first input.  
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If the data are already ordinal, selecting cardinal will remove the ordinal setting. Similarly, if already 

cardinal, selecting ordinal will set this property. If cardinal or ordinal and the ‘type’ selection matches 

the current type there are two options: (i) if the top box contains the word ‘order’, the definitions in the 

‘Matching category names’ entry box are used to reorder the categories, otherwise (ii) the definitions 

in the ‘Matching category names’ entry box are used to rename the categories. 

Project>Cases>Save: select the Case to be saved from the list of Cases, select whether to save the 

Case as a dstable or a table and name the file. The dataset dstable or table are saved to a mat file.  

Project>Cases>Delete: select the Case(s) to be deleted from the list of Cases and these are deleted 

(model setup is not changed). 

Project>Cases>Reload Case: select a previous model run and reload the input as the current input 

settings. 

Project>Cases>View Case Settings: display a table of the model input parameters used for a selected 

Case. 

Project> Import/Export>Import: load a Case class instance from a Matlab binary ‘mat’ file. Only 

works for data sets saved using Export.  

Project>Import/Export>Export: save a Case class instance to a Matlab binary ‘mat’ file. 

These last two functions can be used to move Cases between projects or models. 

NB: to export the data from a Case for use in another application (eg text file, Excel, etc), use the 

Project>Cases>Edit Data Set option to select and then use the ‘Copy to Clipboard’ button to paste the 

selection to the clipboard. 

 

3.4 Setup 
The setup menu provides a series of menus to enable different components of the model to be defined.  

3.4.1 Table Data 
Setup>Import Table Data: dialog with sub-menu options to Load, Add, and Delete tabular data.  This 

uses the same functionality as the TableViewer App. 

Select a file to load. When the data has been loaded, the user is prompted to provide a description of 

the data set (a case) and the case is listed on the Cases tab.   

Setup>Import Table Data > Load: the user is prompted for a file. Accepted formats are: 

1. A table or dstable created in Matlab and saved as a mat file 

e.g., >> save('my_table.mat', mytable'), where the table was assigned to the variable ‘mytable’; 

2. As option 1, containing a struct of tables, or dstables, where the fieldnames of the struct define the 

dataset name assigned to each table. 

3. A worksheet in an Excel spreadsheet. If there is more than one worksheet the user is prompted to 

select one. The MatlabTM readtable function is used in 

muiTableImport.loadFile to read the file with the option 

to ReadRowNames set to true. This assumes that the 

first column of the spreadsheet contains unique names 

for the data. The variable names must be valid variable 

names (a valid variable name starts with a letter, 

followed by letters, digits, or underscores). 

The variable names can be edited (number of variables 

should not change) 

Start cell for row of variables 
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Start cell for array of data 

Start cell for column of row names  

4. An ASCII text file using the MatlabTM readtable function. The header contains the variable names 

with tab or comma separation (a valid variable name starts with a letter, followed by letters, digits, 

or underscores). The first column contains the row name (if used) and subsequent columns contain 

the data with the same separator as the header. 

Examples of the spreadsheet and text file formats are provided in Appendix A - Import file formats. 

The user is then prompted for a description of the data source (text string) and a name for the dataset 

(must be a valid MatlabTM variable name or code will try to convert the text entered to a valid name). 

When data are loaded into a dstable the data are assigned dsproperties (i.e., name, description, unit, 

label and qcflag or format – see Appendix B - Data set properties (DSproperties)). By default, these 

are assigned the variable name and qcflag is set to none.  

The user is then prompted to select an option from File, UI and Skip: 

File - loads a file of definitions (.m, text or Excel file)1, or 

UI - uses a UI to input the definitions, 

Skip - skips this step and uses the defaults. 

[NB: when loading a struct of tables from a .mat file it is assumed that these already have 

DSproperties and the UI is used to step through the definitions to provide the opportunity to edit, or 

modify the definitions.] 

Load DSproperties from file: 

A MatlabTM function file that defines a variable that holds a struct of the DSproperties, as explained in 

Appendix B - Data set properties (DSproperties) and illustrated in Appendix C – Sample DSproperties 

for data import. 

A text file lists the definitions of the variables only as illustrated in Appendix C – Sample 

DSproperties for data import. These are then scrolled through using the UI (see below) and allows the 

Description of the rownames to be edited to suit the dataset.  

Load DSproperties using UI: 

Data in the imported table is used, where possible, to define the meta-

data for each variable. The user is then prompted to either accept the 

definition to be assigned for each variable in turn. As well as the 

variable name, this includes a description, units, the label to use when 

plotting this and similar variables, and the quality control flag for 

variables, or format for the rowname. The format property defines the 

date format, when used, using the Matlab identifiers (e.g., 'dd-MM-

yyy HH:mm:ss' for 26-Oct_2024 13:22:00 date style). 

NB : the UI prompts for Dimensions with a value of 0. For scalar table 

data, only rows are used to hold a unique identifier (i.e., a dimension). 

Accept the default value to continue. 

When the data has been loaded, the user is prompted to provide a 

description of the data set (case) and this is listed on the Cases tab.  

All input data sets can be viewed (just one variable at a time) on the 

Q-Plot tab.  

 

 

1 Sample files are provided in the /example folder. 
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Individual tables can be viewed on the Table tab and default plots are accessed using the Q-Plot tab. 

Setup>Import Table Data >Add to Table: There are three options for adding data: 

Setup> Import Table Data >Add to Table >Rows: add rows of data to an existing dataset. Data can be 

loaded from a text file, table or spreadsheet but the number of variables should be the same as the 

existing dataset2. 

Setup> Import Table Data >Add to Table >Variables: add variables to an existing dataset. Data can 

be loaded from a text file, table or spreadsheet but the number of rows should be the same as the 

existing dataset3. 

Setup> Import Table Data >Add to Table >Dataset: this links another dataset to a selected Case 

record. The dataset is loaded using the same process as used to Load data (see above). 

The user is prompted to choose the existing case and/or dataset that the data is to be added to. 

The next prompt is to define any likely non-standard missing value indicators. The incoming 

table/spreadsheet is then concatenated to the existing table. The data added can be as additional rows, 

in which case the first column of the incoming table is used to define row names and these must be 

unique for the combined table and the number of variables must match the existing table. Or the 

incoming table/spreadsheet can contain additional variables, in which case the incoming table must 

have the same number of rows as the existing table.  When variables are added, the user is prompted to 

accept or update the meta-data for each new variable. 

Setup>Import Table Data >Delete from Table: There are three options for adding data: 

Setup> Import Table Data >Delete from Table >Rows: select rows to be deleted. 

Setup> Import Table Data >Delete from Table >Variables: select variables to be deleted. 

Setup> Import Table Data >Delete from Table >Dataset: select dataset to be deleted. If there is only 

one dataset linked to the case you will be prompted to use Project>Cases>Delete. 

 

3.4.2 Spatial Data 
Setup>Import Spatial Data: 

These menu options are to load data that is not tabular and requires a bespoke format file to load the 

data. The data can be loaded can be in any form that can be held in a dstable and typically will be 

vector or matrix data, or images (e.g. jpeg). The load process is described below and the procedure to 

define a bespoke data format is set out in Section 4.1. 

Setup>Import Spatial Data >Load or Add dataset: The first prompt is for the type of data to import. 

Currently the options available in include a Bathymetry, Surface Area, Width, Image and GeoImage. 

These are explained in more detail in Section 4.1. The file name of the dataset define the ‘location’ 

used to define the Case and should be unique. When adding datasets with a file that has the name of a 

location that already exists it will be added to the case as a new dataset, if it is a different type of data, 

whereas if it is the same as an existing dataset the user is given the option to overwrite the existing 

dataset, or provide an alternative name for the dataset. 

Setup>Import Spatial Data >Load archive file: load an estuary Case from an archived ASCII file. The 

archive file is created using Tools >Archive and the format of the file is detailed in Appendix F – 

Archive File Format. 

Setup>Import Spatial Data >Add/Edit Summary: add or edit a short description of the estuary 

 

2 Formats for adding data are the same as for loading data, as detailed in the Appendices with sample files 

provided in the /example folder. 
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Setup>Import Spatial Data >Add/Edit Location: add or edit the coordinates of the estuary and the grid 

projection used for the coordinate system. 

Setup>Import Spatial Data >Delete dataset: select dataset to be deleted. If there is only one dataset 

linked to the case you will be prompted to use Project>Cases>Delete. 

When loading bathymetry, the first prompt presents the maximum and minimum Z values in the grid 

and the option to limit the range of data to be loaded (values outside the range are set to NaN). The 

grid is then plotted on a figure with multiple options to rotate or flip 

the grid, and invert the direction of the X and Y axes. This is 

illustrated below for the case of the Oka estuary in northern Spain. In 

(b) the orientation of the grid and axes are geographically correct, 

whereas in (c) the estuary channel has been aligned with the X-axis, 

whilst keeping the grid coordinates correct relative to the channel (X-

axis is descending). This is required if the Inlet Property tools for 

hypsometry and gross properties are to be used as these assume the 

channel is aligned to the X-axis. 

 

(a) raw data loaded from file 

 

 

(b) grid flipped UD and Y-axis inverted to give 

correct geographical orientation 

 

(c) grid flipped UD and rotated -90 to align 

estuary channel with x-axis (note X-axis is 

descending but correct geographically) 

 

Button options: 

Accept – uses the current settings to load grid 

FlipLR – flips the grid left to right (horizontally) 

FlipUD – flips the grid up-down (vertically) 

+90 – rotates grid clockwise 

-90 – rotates grid anti-clockwise 

invX – reverses the direction of the X-axis 

invY – reverses the direction of the Y-axis 

Reset – restores the settings as loaded from file 

The data is then loaded and the user is prompted for a description (working title) for the data set. 

 

3.4.3 Estuary Property Tables 
Setup>Estuary Properties: property tables for tides and river discharge can be loaded, edited and 

deleted using (Load, Edit, Delete submenus for each option).  Examples of suitable Excel table 

formats and DSproperties to add these tables are detailed in Appendix E – Estuary Property Tables: 
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Example Formats. Using the Load for File option, data can be added to multiple cases using any set of 

variables with suitably defined DSproperties. Alternatively, tables for a single estuary can be added 

using the default set of DSproperty definitions for each type of property table (these definitions are as 

used in Appendix E). 

Setup> Estuary Properties>Tidal Levels: a table of the elevations that define, for example, spring and 

neap tides. 

Setup> Estuary Properties>River Discharge: a table of river discharges that define, for example, the 

annual and seasonal discharges into the estuary. 

Setup> Estuary Properties>Classification: a table of classifications that define, for example, the 

estuary type, tidal type and geomorphic type. 

 

3.4.4 Grid Tools 
Setup> Grid Parameters: The grid is defined by x and y ranges and 

intervals for both axes. 

Upper and lower limits for the x co-ordinates 

Grid spacing along the x-axis 

Upper and lower limits for the y co-ordinates 

Grid spacing along the y-axis 

The vertical interval to be used when computing the channel 

hypsometry. 

A range of tools to manipulate cartesian grids. 

Setup>Grid Tools>Translate Grid: interactively translate grid x-y coordinates. 

Setup>Grid Tools>Rotate Grid: interactively flip or rotate grid3.    

Setup>Grid Tools>Re-Grid: re-grid a gridded dataset to match another grid or to user specified 

dimensions. 

Setup>Grid Tools>Sub-Grid: interactively define a sub-grid and save grid as a new Case.                

Setup>Grid Tools>Combine Grids: superimpose one grid on another based on maximum 

or minimum set of values. 

Setup>Grid Tools>Add Surface: add horizontal surface to an existing grid. 

Setup>Grid Tools>Infill Surface: spatial interpolation to infill areas with no data4. 

Setup>Grid Tools>To curvilinear: map grid from cartesian to curvilinear coordinates.  

Setup>Grid Tools>From curvilinear: map grid from curvilinear to cartesian coordinates. 

 

3 Rotation re-orients the z grid and swaps x and y axes when rotating +/-90o. However, it does not change the 

order of the x and y axes. Consequently, rotating +90 o or flipping left-right reverses the co-ordinate values on 

the x-axis and rotating -90 o or flipping up-down reverses the co-ordinate values on the y-axis. 
4 Uses inpaint_nans by John Enrico, which solves approximation to one of several pdes to interpolate and 

extrapolate holes in an array (see https://www.mathworks.com/matlabcentral/fileexchange/4551-inpaint_nans). 

https://www.mathworks.com/matlabcentral/fileexchange/4551-inpaint_nans
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Setup>Grid Tools>Display Dimensions: display a table with the dimensions of a selected grid. 

Setup>Grid Tools>Difference Plot: generate a plot of the difference between two grids. 

Setup>Grid Tools>Plot Sections: interactively define section on a grid and plot as sections. 

Setup>Grid Tools>Grid Image: save grid as an image struct with fields 'XData', 'YData', 'CData', 

'CMap', 'CLim' (includes option to resize large grids; > 1Mb). 

Setup>Grid Tools>Digitise Line: interactively digitise a line (with option to add elevations) using 

selected grid as base map. 

Setup>Grid Tools>Export xyz Grid: select a Case and export grid as xyz tuples. 

 

3.4.5 Section Tools 
Setup>Sections A set of tools to create sections along one or more estuary reaches, define the 

connectivity, extract the sections for use in computing the width hypsometry (Setup > Add 

Hypsometry from Grid > Width). The steps for defining the boundary, centrelines and section lines 

have sub-menus as follows: 

Setup>Sections>‘line type’ >Generate - use the built in tools to aid the creation of the lines. This 

option can be used to modify existing linework, or create new linework. The Sections > Boundary tool 

also has an option to copy the Waterbody linework as an input. 

Setup>Sections>‘line type’ >Load - load a shapefile with the lines to be used. 

Setup>Sections>‘line type’ >Edit - interactively digitise or edit the linework. 

Setup>Sections>‘line type’ >Delete - delete the saved lines for the selected Case. 

Setup>Sections>‘line type’ >Export - export the saved lines for the selected Case to an ASCII text file 

(.txt), a Matlab data file (.mat), or a shape file (.shp). Text files include a header with details of the 

source and line type. The same information is included in the saved metadata struct for the other file 

formats. 

The Point and Line tools have a menu that is accessed by right clicking the mouse in the figure but 

outside the plot axes. This provides access to a set of context sensitive menus. They all include the 

Figure option, which provides access to the following options: 

Figure > Redraw: update the line work of points and lines in the plot; 

Figure > Undo: revert to the previously save linework. If Save has not been used in the 

session, this will revert to any imported line work; 

Figure > Distance: display the distance between two points; 

Figure > Save: save the current points and lines; 

Figure > Save & Exit: save the current data and exit; 

Figure > Quit: exit without saving. If new points and lines have been created the user is 

prompted to confirm that these do no need to be saved. 

When using the Edit option there are menus options for points and lines as follows: 

Point > Add: add one or more points; 

Point > Edit: edit the position of any existing points; 

Point > Delete: delete existing points; 

 

Line > Add: add one or more lines (each line is terminated with a NaN point); 

Line > Edit: edit the points in a line; 
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Line > Extend: add points to the end of a line; 

Line > Insert: insert points within a line; 

Line > Join: join two lines together; 

Line > Split: divide a line into two; 

Line > Delete > Points: delete one or more points in a line. 

Line > Delete > Lines: delete one or more lines. 

For details of the conventions used for points and lines see the Point & Line documentation. 

Bespoke tools are provided to create the different line types as follows: 

Setup > Sections > Boundary - Load or create a polygon, or set of lines, that define the estuary 

shoreline. This is used to determine the extent of the section lines. Consequently, it does not have to be 

an exact, or detailed, representation of the actual shoreline but should be positioned at an elevation that 

captures the desired range for the hypsometry. For example, to examine future change this might be 

close to the contour for Highest Tide + 1m to account for surge or sea level rise. Where there are 

branches, or multiple islands, additional internal “boundaries” can be added to improve the ability of 

the Clip tool to create section lines within defined zones (see Section Lines). Bespoke menus for the 

Boundary tool include the Line and Figure menus detailed above and: 

Boundary > Resample: define the sampling interval along the line and resample the linework 

at the required intervals; 

Boundary > Smooth: use either a moving average of ‘sgolay’ method to smooth the lines; 

Boundary > Reset: clear the existing lines and generate a new contour using NaN or an 

elevation. 

Setup>Sections>Channel Network - Individual reaches are captured by either:  

(i) Defining the end points and using a function to trace the deepest channel between the 

two points. When this option is selected, the user is prompted to define the maximum 

accessible water level, the depth exponent (value between 5 and 10 usually works 

well, whereas smaller values tend to follow the shore in meandering channels), and 

the sampling interval for the linework that is generated; or 

(ii)  Using the Line editing tools to Add and Edit centrelines. For complex networks using 

this option to add branches, in conjunction with the Resample and Smoothing tools 

can provide centrelines to generate section lines that require less subsequent editing. 

 

The menu options provided include Line and Figure as detailed above and the Centreline 

menu: 

Centreline > Set: define start and end points and generate a centreline that attempts to find the 

shortest distance between the end points constrained to also find the deepest part of the 

channel. 

Centreline > Resample: define the sampling interval along the line and resample the linework 

at the required intervals; 

Centreline > Smooth: use either a moving average of ‘sgolay’ method to smooth the lines; 

Centreline > Reset: clear the existing lines. 

NB: Centrelines should start at the seaward end and be drawn in a landward direction. The first line 

should start at the mouth, the first point being used to define the mouth section. The order of branches 

is not critical but it makes the plots clearer if they are approximately ordered based on distance from 

the mouth. 
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Setup>Sections>Section Lines - The Boundary and Centreline need to be defined before calling this 

option. In addition to the Figure menu there is a Sections menu, with the following options: 

Sections > Set: uses the points on the centreline to define a set of cross-sections. The user is 

prompted to input the length of the line either side of the centreline and the sections are then 

generated; 

Sections > Clip: clip the cross-section lines to the defined boundary; 

Sections > Add: add one or more points to the centreline (either by inserting points, or as an 

extension of a line). This adds sections at the new centreline points; 

Sections > Edit: adjust the end points of existing sections; 

Sections > Delete: remove one or more sections; 

Sections > Reset: revert to the initial centreline defined sections; 

Sections > Label: add numbered labels to the sections. 

NOTE: Clip shortens the lines based on the intersection with the boundary. Sections that do not cross 

the boundary within the specified section length are retained for editing. Re-running Clip after some 

editing of the sections can result in lines being omitted. It is therefore better to Set the lines before 

applying the Clip tool. Careful definition of the boundary linework and centrelines can greatly reduce 

the need for editing. This is therefore usually an iterative process, using Set and Clip to examine the 

section lines and then editing the boundary and centrelines to improve the constraints so that final 

editing to remove crossing lines is kept to a minimum. 

Using the 3 sets of lines (boundary, centreline and section lines), the cross-sections can be extracted 

and the channel connectivity can be defined: 

Setup>Sections>Sections - extract the depths along a set of cross-sections. Section lines need to have 

been defined before using this option. NB: the upper level defined for the sections should be above the 

highest level required for subsequent analysis (e.g HAT+slr). 

Setup>Sections >Channel Links - define the connections between the different reaches of the channel 

network. The Centreline needs to be defined before using this option. 

 

There are then options to view the various types of line work: 

Setup> Sections>View Sections>Layout - creates a plot of the boundary, centre-line and section lines. 

Setup>Sections>View Sections>Sections - creates a composite plot of all the sections (the individual 

sections can be queried by clicking the mouse on a section line). 

Setup>Sections>View Sections>Network - creates a graph plot of the network with the nodes labelled 

with the index of the point in the centre-line line set and the distance from the first point in 

parenthesis, with the line number defined on the edges between the nodes. 

 

Setup>Waterbody 

Similar to the boundary tool used for creating Sections, the Waterbody tools enable a bounding 

polygon to be defined for use when computing the surface area hypsometry (Setup>Add Hypsometry 

from Grid>Surface area). As with Sections there are options to 

Setup>Waterbody >Generate - use the built in tools to aid the creation of the lines. This option can be 

used to modify existing linework, create new linework, or copy the Sections > Boundary tool 

linework. 

Setup>Waterbody >Load - load a shapefile with the lines to be used. 
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Setup>Waterbody >Edit - interactively digitise edit the waterbody linework. 

Setup>Waterbody>Delete - delete the saved lines for the selected Case. 

Setup>Waterbody >Export - export the saved lines for the selected Case to an ASCII text file (.txt), a 

Matlab data file (.mat), or a shape file (.shp). Text files include a header with details of the source and 

line type. The same information is included in the saved metadata struct for the other file formats. 

Setup>Waterbody>View - creates a plot of the boundary. 

3.4.6 Other Setup options 
Setup>Input Parameters: enter and edit the specified model parameters. The input parameters can be 

viewed on the Inputs tab. 

Setup>Input Data>Model Constants: various constants are defined for use in models, such as the 

acceleration due to gravity, viscosity and density of sea water, and density of sediment. Generally, the 

default values are appropriate (9.81, 1.36e-6, 1025 , 2650 respectively) but these can be adjusted and 

saved with the project if required. 

 

3.5 Tools 
Tools has three options: Models, Derive Output and User Tools. 

3.5.1 Hypsometry and Gross Properties 
Tools >Hypsometry: use a loaded bathymetry data set to construct surface area, or along-channel 

width hypsometry datasets. These options replicate the data formats that can be imported using the 

Import Spatial Data options. 

Tools >Hypsometry >Surface area: derive the surface area hypsometry from an imported bathymetry 

(to save space import the grid, run the utility and then delete the grid). 

Tools >Hypsometry >Width: derive the along-channel width hypsometry from an imported 

bathymetry (to save space import the grid, run the utility and then delete the grid). 

NB: in both cases, the upper level defined for the hypsometry should be above the highest level 

required for subsequent analysis (e.g HAT+slr). 

Tools >Gross Properties: the large-scale, or gross, morphological properties can be added as a table 

once, Tidal Levels and a Surface area or Width hypsometry have been defined. Add a row of data to 

the morphological properties table by selecting a hypsometry and a tidal data set to use. 

 

3.5.2 Combined tables and Archiving 
Tools >Combine Tables: the tabular property data for individual estuaries can be combined into a table 

allowing intercomparison between estuaries. The estuary Cases can be in the current file or in saved 

project files.  The output is a table of values for a number of estuaries. The table cannot accept data 

from multiple sources with the same estuary name (row names must be unique). Similarly, when 

combining Gross Property tables, it is necessary to select a single row for inclusion in the combined 

table. These can be selected based on the Source and Notes in fields of the source tables. 

Tools >Archive: save an estuary Case as an ASCII text file. This file can be loaded into EstuaryDB 

using Setup>Import Spatial Data >Load archive file. The format of the saved file is detailed in 

Appendix F – Archive File Format.  
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3.5.3 Derived Output 
Tools> Derive Output: data that has been added 

(either as data or modelled values) can be used 

to derive new variables. The UI allows the user 

to select data and use a chosen selection of 

data/variable/range to define either a Variable, 

XYZ dimension, or Time. Each data set is 

sampled for the defined data range. If the data 

set being sampled includes NaNs the default is 

for these to be included (button to right of Var-

limits is set to ‘+N’). To exclude NaNs press 

the button so that it displays ‘-N’.  

The selection is assigned by clicking one of the 

X, Y or Z buttons. The user is prompted to 

assign a Variable, XYZ dimension, or Time (the options available varies with the type of variable 

selected) – see Section 3.9 for details of how this works.  

An equation is then defined in the text box below using the x, y, z or t variables5. Based on the user 

selection the routine applies the defined variable ranges to derive a new variable. In addition text 

inputs required by the call and the model object (mobj) can also be passed. 

Adding the comment %time or %rows, allows the the row dimension to be added to the new dataset. 

For example if x and y data sets are timeseries, then a MatlabTM expresion, or function call, call can be 

used to create a new time series as follows: 

x^2+y  %time 
 

The output from function calls can be figures or tables, a single numeric value, or a dataset to be saved 

(character vectors, arrays or dstables). External functions should return the table RowNames (e.g., 

time or location) as the first variable (or an empty first variable), followed by the other variables to be 

saved. 

If there is no output to be passed back the function should return a string variable. 

If varout = 'no output'; this suppresses the message box, which is used for single value outputs. 

For expressions that return a result that is the same length as one of the variables used in the call, there 

is  the option to add the variable to the input dataset as a new variable. In all there are three ways in 

which results can be saved: 

1. As a new dataset; 

2. As an additional variable(s) to one of the input datasets; 

3. As an additional variable(s) to some other existing dataset. 

For options 2 and 3, the length of the new variables must be the same length (numbere of rows) as the 

existing dataset. 

 

An alternative when calling external functions is to pass the selected variables as dstables, thereby also 

passing all the associated metadata and RowNames for each dataset selected. For this option up to 3 

variables (plus time if defined for a selected variable) can be selected but they are defined in the call 

using dst, for example: 

[time,varout] = myfunction(dst, 'usertext', mobj); 
 

 

5 Various pre-defined function templates can be accessed using the ‘Function’ button. Alternatively, text can be 

pasted into the equation box from the clipboard by right clicking in the text box with the mouse. 
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dst = myfunction(dst, 'usertext’, mobj); 
 

This passes the selected variables as a struct array of dstables to the function. Using this syntax the 

function can return a dstable, or struct of dstables, or a number of variables. When a dstable, or struct 

of dstables is returned, it is assumed that the dsproperties have been defined in the function called and 

dstables are saved without the need to define the meta-data manually. 

Some further details on using this option and the ‘Function’ library available are provided in Section 

4.2. 

3.5.4 User Tools 
Tools> User Tools: calls function ‘edb_user_tools.m’, which includes a function to: 

(i) create a figure tabulating a dataset (tabular data only); 

(ii)  add additional properties to a table and  (tabular estuary properties data only); 

(iii) run and save the results of a convergence analysis (e.g. for along channel properties); 

(iv) the option for the user to add functions as required. 

 

3.6 Analysis 
Plotting and Statistical Analysis both use the standard Data selection UI. These both require Case, 

Dataset and Variables to be selected from drop-down lists and assigned to a button. Further details of 

how this works are given in Section 3.9. 

3.6.1 Plotting 
Analysis>Plot menu: initialises the Plot UI to select variables and produce several types of plot. The 

user selects the Case, Dataset, and Variable to be used and the plot Type from a series of drop-down 

lists. There are then buttons to create a New figure, or Add, or Delete variables from an existing figure 

for 2D plots, or simply a Select button for 3D and 4D plots. The following figures illustrate the options 

available. 

 

2D plot 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign a variable, or a dimension, to the Var and X 

buttons to set the Y and X axes, respectively 

Each selection can be scaled (log, normalised, etc) 

and the range to be plotted can be adjusted when 

assigning the selection to a button. 

> Select plot type (line, bar, scatter, stem, etc) 

Control Buttons: 

→ : updates the list of Cases  

XY :  swaps the X and Y axes 

+ : switches between cartesian and polar plot type 

If polar selected then Ind assumed to be in degrees. 
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3D plot 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign selections to the Var, X and Y buttons 

Take care to ensure that the assignments to X and Y 

correctly match the dimensions selected for the 

variable (including any adjustment of the dimension 

ranges to be used). 

> Select plot type. 

 

Control Buttons: see 2D plot above. 

 

For all plot types, when the data has more dimensions than the plot or animation the user is prompted 

to sub-select from the data (by selecting sampling values for the dimensions that are not being used). 

 

Selection of ‘User’ plot type in Plotting UI 

Calls the user_plot.m function, where the user can define a workflow, accessing data and functions 

already provided by the particular App or the muitoolbox. The sample code can be found in the 

psfunctions folder  and illustrates the workflow to a simple line plot using x-y data from the 2D tab 

and a surface plot using x-y-z data from the 3D tab. 

 

3.6.2 Statistics 
Analysis> Statistics: several statistical analysis options have been included within the Statistical 

Analysis GUI. The tabs are for General statistics, Timeseries statistics, model comparisons using a 

Taylor Plot, and the generation of a new record based on the statistics over the Intervals defined by 

another timeseries. 

General tab 
The General tab allows the user to apply the following statistics to data loaded in ModelUI:  

1) Descriptive for X: general statistics of a variable (mean, standard deviation, minimum, maximum, 

sum and linear regression fit parameters). Only X 

needs to be defined. The range of the variable can be 

adjusted when it is assigned to the X button (see 

Section 3.9). If the variable being used is a multi-

dimensional matrix (>2D), the user is prompted to 

define the range or each additional dimension, or 

select a value at which to sample. The function can 

return statistics for a vector or a 2D array. 

 

The results are tabulated on the Stats>General tab and 

can be copied to the clipboard for use in other 

applications. 
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2) Regression: generates a regresion plot of the dependent variable, Y, 

against the independed variable, X. For time series data, the default data 

range is the maximum period of overlap of the two records. For other data 

types the two variables must have the same number of data points. After 

pressing the Select button, the user is prompted to select the type of model 

to be used for the regression. The results are output as a plot with details of 

the regression fit in the plot title. 

 

 

 

3) Cross-correlation: generates a cross-corrleation plot of 

the reference variable, X, and the lagged variable, X (uses 

the Matlab ‘xcorr’ function). For time series data, the 

default data range is the maximum period of overlap of 

the two records. For other data types the two variables 

must have the same number of data points. This produces 

a plot of the cross-correlation as a function of the lag in 

units selected by the user. 

 

4) User: calls the function user_stats.m, in which the user can implement their own analysis methods 

and display results in the UI or add output to the project Catalogue. Currently implements an 

analysis of clusters as detailed for Timeseries data below. 

 

3.6.3 Bespoke Plots 
Analysis > Tabular Plots: Bespoke plots for scalar tabular data. 

(i) plot a scatter diagram of two or three variables from any case (selected variables must be the same 

length); 

(ii) plot a bar chart of a variable with the bars coloured based on a selected classification variable 

(from the same dataset as the main variable); 

(iii) plot a range plot by selecting low-mean-high values of two properties (eg tidal ranges and river 

discharge); 

(iv) plot a Geyer-McCready plot (Figure 6 in 2014 paper) using the gross properties of the estuaries 

 

(i) Scatter plot of two variables 

from a tabular data set with 

markers scaled by a third 

variable. Selection button 

provides a display of the 

variable selection in more 

detail. 

Each variable is specified as  
Case(Dataset)Variable(Dimension) 
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(ii) Type plot – a bar plot of a variable for various locations with the bar color reflecting the 

geomorphological classification. Note: log scale button applied to y-axis and NaN button 

used to remove locations with no data. 

 

(iii) Range plot – use the central, upper and lower values of two variables to create a box plot. 

The selection process is quite involved and a set of selections can be saved and reloaded to 

aid subsequent replotting. 
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(iv) Geyer-McCready plot – reproduces a version of Figure 6 in 2014 paper using the gross 

properties of the estuaries. The numbers in brackets for the title are the selection made 

when creating the plot. There are 3 options for Hydraulic depth, 2 options for tidal prism 

and 2 options for Cross-sectional area at the mouth, which use different methods to estimate 

each value: 

Hydraulic depth: average of high and low (V/S), mean tide (V/S) and the first option scaled 

to approximate the value at the mouth (x1.5). 

Tidal prism: Surface area at mean tide x the tidal ranges (spring, mean and neap), and the 

volume between high and low water scaled by the tidal ranges relative to mean tidal range. 

CSA at mouth: area at mean tide, or the width at mean tide time the system hydraulic depth. 

 [NB: this is experimental and needs further development]. 
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Analysis > Hypsometry Plots: Bespoke plots for the surface area and width hypsometry data sets. 

(i) Surface area hypsometry plot 

 

(ii) Width Hypsometry plot 

Reach plot shown 

below. To convert the 

single column of 

subplots to 2 columns 

use the function 

reshape_axes(hf) where 

hf is a handle to the 

figure to be modified, or 

Simply reshape_axes 

with the plot to be 

modified as the currently 

selected figure.  
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(iii) Convergence plot has panels for along-channel variation of width, csa and depth and a 

fourth panel for an image of where the sections were taken (if available in the dataset). 

 

 

Analysis > User Plots: calls function ‘edb_user_plots.m’, allowing additional plots to be added as 

required. 
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3.7 Help 
The help menu provides options to access the App documentation in the MatlabTM Supplemental 

Software documentation, or the App manual. 
 

3.8 Tabs 
To examine what has been set-up the Tabs provide a summary of what is currently defined. Note: the 

tabs update when clicked on using a mouse but values displayed cannot be edited from the Tabs. 

Estuary and Data: lists the data loaded and the cases that have been run with a case id and description. 

Clicking on the first column of a row generates a table figure with details of the variables for the case 

and any associated metadata. Buttons on the figure provide access the class definition metadata, source 

information (files input or models used) and any user data (e.g., tables of derived parameters) that is 

saved with the data set.  

Inputs: tabulates the system properties that have been set (display only). 

Properties: tabulates a selected dataset (display only) and has the following sub-Tabs: 

Summary: displays the summary description for a selected estuary. 

Dataset: tabulates Case datasets that are scalar, vector or matrices. 

Tides: tabulates any tidal elevation data added for the specific estuary. 

Rivers: tabulates any river discharge data added for the specific estuary. 

Classification: tabulates summary classification data for the specific estuary (e.g. estuary type, 

tidal type, etc). 

Morphology: tabulates the gross properties for the estuary derived from either the surface area 

hypsometry or the width hypsometry and selected tidal range. 

Q-Plot: displays a quick-plot defined for the class of the selected case (display only). 

Stats: displays a table of results for any analyses that have been run (can be copied to clip board). 
 

3.9 UI Data Selection 
Functions such as Derive Output (3.5.3), Plotting (3.6.1) and Statistics (3.6.2) use a standardised UI 

for data selection. The Case, Dataset and Variable inputs allow a specific dataset to be selected from 

drop down lists. One each of these has been set to the desired selection the choice is assigned to a 

button. The button varies with application and may be X, Y, Z, or Dependent and Independent, or 

Reference and Sample, etc. Assigning to the button enables further sub-sampling to be defined if 

required. Where an application requires a specific number of dimensions (e.g., a 2D plot), then 

selections that are not already vectors will need to be subsampled. At the same time, the range of a 

selected variable can be adjusted so that a contiguous window within the full record can be extracted. 

In most applications, any scaling that can be applied to the variable (e.g., linear, log, relative, scaled, 

normalised, differences) is also selected on this UI. The selection is defined in two steps: 
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Step 1.  

Select the attribute to use. This can be the variable 

or any of its associated dimensions, which are 

listed in the drop-down list. 

The range for the selection can be adjusted by 

editing the text box or using the Edit (Ed) button. 

Any scaling to be applied is selected from the 

drop-down list.+ 

Press Select to go to the next step or Close to quit. 

+ scaling options include Linear; Log; Relative (V-V(x=0)); Scaled (V/V(x=0)); Normalised; Normalised (=ve); Differences; 

Rolling mean. 

The number of variables listed on the UI depends on the dimensions of the selected variable. For each 

one Select the attribute to use and the range to be applied.  

Step 2 - Variable only has 

dimension of time. 

 

No selection to be made. 

Edit range if required. 

 

 

 

Step 2 - Variable has 3 dimensions but only 

2 are needed for the intended use. 

 

Select the 1st variable to use as a dimension. 

Edit range if required. 

 

Select the 2nd variable to use as a dimension. 

Edit range if required. 

Use the slider or the Edit (Ed) button to set 

the value of the dimension to use. (A value of 

t=500 is selected in the example shown). 

Press Select to accept the selection made. 

[NB: Only unused dimensions can be selected from the Select drop-down lists. To adjust from the 

default list this can sometimes require that the second Select list-box is set first to allow the first Select 

list-box to be set to the desired value.] 

The resulting selection is then detailed in full (including the ranges or values to be applied to all 

dimensions) in the text box alongside the button being defined. 

Note where a variable is being selected as one property and a dimension as a second property, any 

sub-selection of range must be consistent in the two selections. This is done to allow variables and 

dimensions to be used as flexibly as possible.  
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The UI treats any form of text data (char, string, cellstr, categorical, etc) as a list. To do this any 

variable of these data types uses categories derived by making the list categorical. The range is then 

based on the order of the categories, selecting all values between the selected end members. To change 

the order, modify the data type to categorical and order the categories (see Project>Cases>Modify 

Variable Type in Section 3.3Error! Reference source not found.). 

3.10 Accessing the tables 
Estuary specific data sets – Grid, Surface Area, Width and Images – are all saved as part of the estuary 

Case record (mobj.Cases.DataSets.EDBimport.Data.(<datasetname>), where mobj is an instance of 

the EstuaryDB). The surface area boundary is held in the class Waterbody property  (obj.Waterbody, 

where obj is the Case instance of the EDBimport class). The cross-sections are held in the class 

Sections property. This holds an instance of the PL_Sections class, with properties Boundary, 

ChannelLine, ChannelProps, SectionLines and XSections for the linework used to extract the width 

hypsometry. The various estuary property tables are held in properties of the EDBimport class. These 

include the rpoerties TidalProps for tidal levels, RiverProps for river discharges, ClassProps for 

estuary classification and GrossProps for the estuary gross morphological properties. All data are held 

in dstables with defined DSproperties. 

 

3.11 Accessing data from the Command Window 
In addition to the options to save or export data provided by the Project>Cases>Save and 

Project>Import/Export options, data can also be accessed directly for use in MatlabTM, or to copy to 

other software packages. This requires use of the Command Window in MatlabTM, and a handle to the 

App being used. To get a handle, open the App from the Command Window as follows: 

>> myapp = <AppName>;   e.g., >> as = Asmita; 

Simply typing: 

>> myapp 

Which displays the results shown in the left column below with an explanation of each data type in the 

right hand column. 

myapp =  

  <AppName> with properties: 

 

Purpose 

       Inputs:        [1×1 struct] A struct with field names that match all the model parameter input 

fields currently  

        Cases:       [1×1 muiCatalogue] muuiCatalogue class with properties DataSets and Catalogue. The 

former holds the data the latter the details of the currently held 

records. 

        Info:         [1×1 muiProject] muiProject class with current project information such as file and 

path name. 

       Constants: [1×1 muiConstants] muiConstants class with generic model properties (e.g. gravity, etc). 

 

To access current model settings, use the following: 

>> myapp.Inputs.<InputClassName> 

To access the listing of current data sets, use: 

>> myapp.Cases.Catalogue 

To access imported or model data sets, use: 

>> myapp.Cases.DataSets.<DataClassName> 
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If there are more than one instance of the model output, it is necessary to specify an index. This then 

provides access to all the properties held by that data set. Two of these may be of particular interest, 

RunParam and Data. The former holds the input parameters used for that specific model run. 

RunParam is a struct with fields that are the class names required to run the model (similar to Inputs 

above). The Data property is a model specific stuct with field names defined in the code for the model 

class. If there is only a single table assigned this will be given the field name of ‘Dataset’. To access 

the dstable created by the model, use: 

>> myapp.Cases.DataSets.<DataClassName>(idx).Data.Dataset 

>> myapp.Cases.DataSets.<DataClassName>(idx).Data.<ModelSpecificName> 

where idx is the index of the class instance (e.g. if there are multiple model runs need to select which 

one. The Catalogue defines the case record (caserec – current position in the catalogue) and case index 

(caseid – a unique case index). [Note: the muiCatalogue class functions caseRec and caseID allow one 

to be obtained from the other. The caseid is saved in the Property CaseIndex for classes that use the 

abstract class muiDataSet. The muiCatalogue method classRec can be used to obtain the classrec 

index i.e., classrec = classRec(muicat, caserec); where muicat is the myapp.Cases instance of the 

muiCatalogue]. 

To access the underlying table, use: 

>> myapp.Cases.DataSets.<DataClassName>(idx).Data.Dataset.DataTable 

The result can be assigned to new variables as required. Note that when assigning dstables it may be 

necessary to explicitly use the copy command to avoid creating a handle to the existing instance and 

potentially corrupting the existing data. 
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4 Supporting Information 
 

4.1 Loading spatial data 
There are currently options to load vector data and images (see Section 3.4.2). The format for loading 

surface area and width hypsometry is defined in a data specific format file (see Appendix D – Bespoke 

data import format file). The formats already provided for can be found in the 

folder …/edb_format_files. Examples of the data for the defined surface area and width formats are 

given in Appendix D. 

The data input for tidal levels and river discharges use similar data formats for the data and the 

DSproperties. Some examples are provided in Appendix E – Estuary Property Tables: Example 

Formats. 

 

4.2 Derive Output 
The Tools> Derive Output option allows the user to make use of the data held within App to derive 

other outputs or, pass selected data to an external function (see Section 3.5.3). The equation box can 

accept t, x, y, z in upper or lower case. Time can be assigned to X, Y, or Z buttons, or simply included 

in the equation as t (as long as the data being used in one of the variables includes a time dimension). 

Each data set is sampled for the defined data range. If the data set being sampled includes NaNs, the 

default is for these to be included (button to right of Variable is set to ‘+N’). To exclude NaNs press 

the button so that it displays ‘-N’. The selection is based on the variable limits defined whenever a 

variable is assigned to X, Y or Z using the X, Y, Z buttons. 

The equation string entered in the UI is used to construct an anonymous function as follows: 

 

or when using dstables: 

 
 

This function is then evaluated with the defined variables for t, x, y, and z and optionally mobj, where 

mobj passes the handle for the main UI to the function. Some functions may alter the length of the 

input variables (x, y, z, t), or return more than one variable. In addition, the variables selected can be 

sub-sampled when each variable is assigned to the X, Y, or Z buttons. The dimensions of the vector or 

array with these adjustments applied need to be dimensionally correct for the function being called. 

This may influence how the output can be saved (see Section 4.2.2). 

If the function returns a single valued answer, this is displayed in a message box, otherwise it is saved, 

either by adding to an existing dataset, or creating a new one (see Section 4.2.2 and 3.5.3).  

NB1: functions are forced to lower case (to be consistent with all Matlab functions), so any external 

user defined function call must be named in lower case. 
 

Equations can use functions such as diff(x) - difference between adjacent values - but the result is n-1 

in length and may need to be padded, if it is to be added to an existing data set. This can be done by 

adding a NaN at the beginning or the end:  

e.g.: [NaN;diff(x)] 
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NB: the separator needs to be a semi-colon to ensure the correct vector concatenation. Putting the NaN 

before the equation means that the difference over the first interval is assigned to a record at the end of 

the interval. If the NaN is put after the function, then the assignment would be to the records at the 

start of each interval.  
 

Another useful built-in function allows arrays to be sub-sampled. This requires the array, z, to be 

multiplied by an array of the same size. By including the dimensions in a unitary matrix, the range of 

each variable can be defined. For a 2D array that varies in time one way of doing this is: 

>> [z.*repmat(1, length(t), length(x), length(y))] 

NB2: the order of the dimensions t, x, y must match the dimensions of the array, z. 
 

NB3: When using Matlab compound expressions, such as the above sub-sampling expression, the 

expression must be enclosed in square brackets to distinguish it from a function call. 

 

Adding the comment %time or %rows, allows the the row dimension to be added to the new dataset. 

For example if x and y data sets are timeseries, then a MatlabTM expresion, or function call, can be 

used to create a new time series as follows: 

x^2+y  %time 

 

4.2.1 Calling an external function 
The Derive Output UI can also be used as an interface to user functions that are available on the 

Matlab search path. Simply type the function call with the appropriate variable assignment and the 

new variable is created. (NB: the UI adopts the Matlab convention that all functions are lower case). 

Some examples of functions provided in EstuaryDB are detailed in Section 4.2.3.  

The input variables for the function must match the syntax used for the call from the Derive Output 

UI, as explained above. In addition, functions can return a single value, one or more vectors or arrays, 

or a dstable (see Section 4.2.2). If the variables have a dimension (e.g., time) then this should be the 

first variable, with other variables following. If there is a need to handle additional dimensions then 

use the option to return a dstable. 

If there is no output to be passed back, the function should return a variable containing the string 'no 

output' to suppress the message box, which is used for single value outputs (numerical or text). 

An alternative when calling external functions is to pass the selected variables as dstables, thereby also 

passing all the associated metadata and RowNames for each dataset selected. For this option up to 3 

variables can be selected and assigned to the X, Y, Z buttons but they are defined in the call using dst, 

for example: 

[time,varout] = myfunction(dst, 'usertext', mobj); 
 
dst = myfunction(dst, 'usertext’, mobj); 

 

where ‘usertext’ and mobj are call strings and a handle to the model, respectively. 

This passes the selected variables as a struct array of dstables to the function. Using this syntax, the 

function can return a dstable or struct of dstables, or as variables, containing one or more data sets. 

 

4.2.2 Input and output format for external functions 
There are several possible use cases: 
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4.2.2.1 Null return 
When using a function that generates a table, plots a figure, or some other stand alone operation, 

where the function does not return data to the main UI, the function should have a single output 

variable. The output variable can be assigned a text string, or ‘no output’, if no user message is 

required, e.g.: 

 

 

4.2.2.2 Single value output 
For a function that may in some instances return a single value this should be the first variable being 

returned and can be numeric or text, e.g.: 

function [qtime,qdrift] = littoraldriftstats(qs,tdt,varargin) 

… 
%Case 1 – return time and drift 

qdtime = array1; 
qdrift = array2; 
%Case 2 – return summary value 

qtime = mean(array2); %return single value 
%Case 3 – return summary text 

qtime = sprintf('Mean drift = %.1f',mean(array2)); %return test string 
… 

end 

 

4.2.2.3 Using variables 
If only one variable is returned (length>1), or the first variable is empty and is followed by one or 

more variables, the user is prompted add the variables to: 

i) Input Cases – one of the datasets used in the function call; 

ii) New Case – use output to define a new dataset; 

iii) Existing Case – add the output to an existing dataset (data sets for the selected existing 

case and the data being added must have the same number of rows. 

In each case the user is prompted to define the properties for each of the variables.  

Note that variable names and descriptions must be unique within any one dataset. 

 

function y = moving(x,m,fun) 
%a single variable is returned with no rows  

 y is a vector or array 

… 
end 

 

or  

function [x,y,z] = afunction(x,m,fun) 
%multiple variables returned but the first variable is empty  

 x = [ ]; 

y and z are a vectors or arrays 

… 
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end 

 

When the first variable defines the rows of a table and subsequent variables the table entries, all 

variables must be the same length for the first dimension. This is treated as a new Case and the user is 

prompted to define the properties for each of the variables. 

function [trange,range,hwl,lwl] = tidalrange(wl,t,issave,isplot) 
%first variable is row dimension followed by additional variables  

 trange,range,hwl,lwl are vectors or arrays 

… 
end 

 

4.2.2.4 Using dstables 
When the output has multiple variables of a defined type it can be more convenient to define the 

dsproperties within the function and return the data in a dstable. This avoids the need for the user to 

manually input the meta-data properties. In addition, if the function generates multiple dstables, these 

can be returned as a struct, where the struct fieldnames define the Dataset name. 

function dst = tidalrange(wl,t,issave,isplot) 
%dst is a dstable with variables, dimensions and dsproprties assigned  
%as required, or a struct of dstables with the struct fieldnames defining 
%each Dataset. 

 dst = … 

… 
end 

 

Similarly, if the input is also using dstables, the syntax is as follows: 

function dst_out = myfunction3(dst_in,'usertext',mobj) 
%dst_in is one or more input dstables, ‘usertext’ is some additional 
%instruction to the function and mobj is a handle to the model  
%allowing access to other datasets. dst_out is either a dstable, or a  
%struct of dstables with the struct fieldnames defining each Dataset. 

 dst = … 

… 
end 

 

4.2.2.5 Saving additional model parameters 
When saving function results as dstable, it is also possible to save additional parameters as part of the 

table. The following example puts a table of summary statistics in the dstable UserData property. 

 

 



 
EstuaryDB manual 

Mar 2025 

 

 

37 

 

Adding functions to the Function library 

To simplify accessing and using a range of functions that are commonly used in an application, the 

function syntax can be predefined in the file functionlibrarylist.m which can be found in the utils 

folder of the muitoolbox.  This defines a struct for library entries that contain: 

• fname - cell array of function call syntax; 

• fvars - cell array describing the input variables for each function; 

• fdesc - cell array with a short description of each function. 

 

New functions can be added by simply editing the struct in functionlibrarylist.m, noting that the cell 

array of each field in the struct must contain an entry for the function being added. In addition, a sub-

selection of the list can be associated with a given App based on the class name of the main UI. To 

amend the selection included with an App or to add a selection for a new App edit the ‘switch 

classname’ statement towards the end of the function. 

The Function button on the Derive Output UI is used to access the list, select a function and add the 

syntax to the function input box, where it can be edited to suit the variable assignment to the XYZ 

buttons.  

4.2.3 Pre-defined functions 
The following examples are provided within EstuaryDB, where the entry in the UI text box is given in 

Courier font and X, Y, Z, refer to the button assignments. 

Some useful examples primarily for timeseries data include: :  

1. Moving Average. There are several moving average functions available from the Matlab 

Exchange Forum, such as moving.m. The call to this function is:   

moving(X, n, 'func') ,  where x is the variable to be used, n specifies the number of points to 

average over and ‘func’ is the statistical function to use (e.g. mean, std, etc). If omitted the mean is 

used. Add %time to the call, to include time in the output dataset. 

2. Moving average (or similar) of timeseries, over defined duration, advancing at defined interval 

movingtime(x, t, tdur, tstep, 'func'), where x is the variable to be used and t the 

associated datetimes (defined by variable selection), tdur is the duration over which to apply the 

statistic, tstep is the interval to advance the start time for the averaging period and ‘func’ is the 

statistical function to use (e.g. mean, std, etc). If omitted the mean is used. tdur and tstep are both 

duration character strings of form ‘2.5 d’. Any of the following duration intervals ca be used:  y, d, 

h, m, or s. Returns a time series based on the defined tstep, where the time used is for the 

beginning of each stepping interval, i.e. every tstep from the start of the record to the nearest 

interval that is less than tdur from the end of the record. 

3. Down-sampling a time series. This allows a timeseries to be resampled at a different interval (that 

must be less than the source timeseries). The call to this function is: 

 downsample(x, t, ’period’, ’method’), where x is the variable to be resampled, time is 

the associated time for that variable, period can be ‘year’, ’month’, ’day’, 'hour', 'minute', 

‘second’, and method can be any valid function call such as ‘mean’, ‘std’, etc. The ‘period’ is 

required but the ‘method is optional and if omitted the mean is used.  

For timeseries with gaps the ‘nanmean’ function is particularly useful but requires the Statistics 

toolbox. 

4. Interpolate and add noise.  To infill a record with additional points and, if required, add some 

random noise to the interpolated values. This is called using: 

interpwithnoise(x, t, npad, scale, method, ispos) , where X is the variable, t is 
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time, npad is the number of points to add between the existing data points, scale determines the 

magnitude of the random noise (a value of 0 results in an interpolated record with no noise), 

method is the Matlab algorithm used for the interpolation (the default is linear) and ispos is a 

true/false flag which sets negative values to zero if true. 

5. Subsample one record at the time intervals of another record (e.g. subsample water levels to be 

at the same intervals as the wave data). Function is: 

subsample_ts(X, t,  mobj), where X and t are the variable to be subsampled and mobj is 

the UI handle (must be mobj). The user is prompted to select the dataset to be used to define the 

time intervals. A time series is returned and added as a Derived data set. The user is prompted to 

define the metadata for the new data set. 

6. Subsample one record based on a threshold defined for another record (e.g. subsample waves 

based on a threshold water level). Function is: 

subsample(X, t,  thr, mobj), where X and t are the variable to be subsampled, thr is the 

threshold value and mobj is the UI handle (must be mobj). The user is prompted to select the 

dataset and variable to be used to define the condition and a condition operator (<=, ==, etc). A 

time series is returned and added as a Derived data set. The user is prompted to define the 

metadata for the new data set. 

7. Phase plot. This function is similar to the recursive plot function but generates a plot based on two 

variables that can, optionally, be functions of time. The call to this function is:  

phaseplot(X, Y , t), where X and Y are the variables assigned to the respective buttons and 

t is time (this does not need to be assigned to a button and  t can be omitted if a time stamp for the 

datapoints is not required). 

8. Recursive plot. Generates a plot of a variable plotted against itself with an offset (e.g. x(i) versus 

x(i+1) ). This is called from the Derive Output GUI using: 

recursive_plot(x, ’varname’, nint), where x is the variable, ‘varname’ is a text string 

in single quotes and nint is an integer value that defines the size of the offset.  

9. Selection of frequency analysis plots of timeseries data using the function: 

frequencyanalysis(X, t,'vardesc') where X is the variable, t is time and vardesc is the 

description of the variable to be used in the plots (optional – defaults to ‘Variable’). Plot options 

include Time series plot of variable, Time series plot of variable above threshold, 'Plot variable 

frequency, Plot variable frequency above threshold, Spectral analysis plot, Duration of threshold 

exceedance, Rolling mean duration above a threshold. 
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5 Program Structure 
The overall structure of the code is illustrated schematically in Figure 1. This is implemented through 

several classes that handle the graphical user interface and program workflows (Main UI) and several 

classes that handle the data manipulation and plotting (Input UIs and Data UIs).  

Figure 1 - – High level schematic of program structure 

 

The interfaces and default functionality are implemented in the EstuaryDB App using the following 

muitoolbox classes depicted in Figure 2, which shows a more detailed schematic of the program 

structure. See the muitoolbox and dstoolbox documentation for more details. 

Figure 2 – schematic of program structure showing how the main classes from muitoolbox and dstoolbox are used 

 

In addition, the EstuaryDB App uses the following classes and functions: 

EstuaryDB – class to define the behaviour of the main UI. 

EDBimport – class to import and provide data specific methods for spatial data (vector and matrix) 

EDBparameters – class to  input parameters. This is a template for the user to define any inputs 

required for bespoke data analysis functions. The class file has to be edited to define the required 

inputs. 
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curvespace - evenly spaced points along an existing curve in 2D or 3D (from Matlab(TM) Forum; Yo 

Fukushima,   https://www.mathworks.com/matlabcentral/fileexchange/7233-curvspace). 

edb_convergence_data – interpolate width hypsometry to return along-channel width and CSA 

variation at selected water levels. 

edb_derived_hypsprops – uses hypsometry of surface area or width to get the vertically integrated 

hypsometry of volume or cross-sectional area. 

edb_derived_props –functions to derive datasets related to estuary gross properties such as hydraulic 

depths, prism etc. 

edb_ grossprops_table – use surface area hypsometry or width hypsometry to compute the gross 

properties of an inlet or estuary. 

edb_hypsometry_plots – plots of surface area and width hypsometry and channel convergence. 

edb_plot_tidelevels - add the high, mean and low water tide levels to a plot. 

edb_read_archive – read an estuary archive file that was written from an EstuaryDB estuary case. 

edb_regression_analysis – regression analysis for selected along-channel variables. Can be plotted or 

added to database table. 

edb_regression_plot – bespoke plot of the results of a regression analysis showing width, csa, and 

depth along with image of estuary (if available). 

edb_s_hypsometry - compute the surface area hypsometry data. 

edb_surfacearea_table - compile the surface area hypsometry dataset. 

edb_table_plots – functions for scalar tabular data to plot a scatter diagram of two variables from any 

case (selected variables must be the same length) and a bar chart of a variable with the bars coloured 

based on a selected classification variable (from the same dataset as the main variable). 

edb_user_plots – provision for user to add own plotting options. 

edb_user_tools –includes a function to create a figure tabulating a dataset and the option for the user 

to add functions as required. 

edb_w_hypsometry - compute the width hypsometry data. 

edb_width_table - compile the width hypsometry dataset. 

edb_waterlevels - select tidal range and return HW,MT,LW for selected range. 

edb_write_archive – write and estuary case to an ASCII text file for archiving. 

geyer_mccready_plot – generate a figure that matches Figure 6 in Geyer W R and MacCready P, 

2014, The Estuarine Circulation. Annual Review of Fluid Mechanics, 46 (1), 175-197. 

Data import format files include: 

edb_bathy_format - defines format for import of xyz bathymetry data. 

edb_image_format - defines format for import of images (eg tiff or jpg). 

edb_s_hyps_format - defines format for import of surface area hypsometry data ([z,S]). 

edb_w_hyps_format - defines format for import of along-channel width hypsometry data ([x,z,W]). 

edb_zm_data_format – format file to load data set of along-channel properties prepared by Dr Zhang 

Min using SeaZone bathymetry for a selection of UK estuaries. 

 

Additional functions include: 

https://www.mathworks.com/matlabcentral/fileexchange/7233-curvspace
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...\muiAppLib\muiAppEstuaryFcns - library of functions for commonly used methods such as sea level 

rise, simple tide simulation, etc. 

...\muiAppLib\muiAppGridFcns - library of functions for a range of grid, point and line manipulation 

methods. 

MatlabTM Mapping toolbox, or  M-Map1.4 (https://www-old.eoas.ubc.ca/~rich/map.html) are used  to 

read shapefiles. As a faster alternative to MatlabTM inpolygon function, the InsidePoly functions can be 

used (https://uk.mathworks.com/matlabcentral/fileexchange/27840-2d-polygon-interior-detection). 

Other classes and functions are used to provide grid tools and interactive point and line tools. These 

are detailed in the online documentation. 

 

 

 

 

 

  

https://uk.mathworks.com/matlabcentral/fileexchange/27840-2d-polygon-interior-detection
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Appendix A - Import file formats 
File formats for Load and Add tabular data 

ASCII text file: 

 

 

Excel spreadsheet: 
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Appendix B - Data set properties (DSproperties) 
Data are stored in a dstable, which extends a Matlab table to hold more comprehensive metadata for 

multi-dimensional data sets. This makes use of a dsproperties class object to hold the metadata. The 

dstable and dsproperties classes are part of the dstoolbox. When loading data or saving model results 

the DSproperties can be defined, loaded and saved when creating a new Case within the application. 

These data are used in the application to provide descriptions of variables and dimensions in UIs, 

define units and formats and generic labels which are used for plots and analysis outputs. Further 

details of the dstable and dsproperties classes can be found in the Matlab Supplemental Software 

Documentation for the dstoolbox. An example of the code to load DSproperties for a time series and a 

variable with 2 spatial dimensions are shown below. 

DSproperties for a set of timeseries variables. 

  
 

DSproperties for a 2D variable with 2 spatial dimensions. 
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Appendix C – Sample DSproperties for data import 
Text file of variable definitions of DSproperties: 

 
 

Matlab function with definition of all DSproperties: 
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Excel file with definition of all DSproperties:  
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Appendix D – Bespoke data import format file 
The format file for a new data set can be edited from the template file provided in 

the ..\muitoolbox\toolbox\muitemplates folder. 

 

There are then 4 functions defined to as defined above. 

Data format:
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Loading the data: 

 
 

Defining the DSproperties: 

 

 

Define the plot for use on the Q-Plot tab: 

To use the class default simply set ok = 0; This will handle timeseries and other vector data. The 

following code implements a bespoke Q-Plot. 
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Optional Quality Control: 
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Sample hypsometry import data set formats: 

(1) Surface area (note the volume data are not loaded). Rows are elevations relative to some 

datum. 

 
 

(2) Width. Rows are elevation relative to some datum and columns are distances from the estuary 

mouth or start of channel. 
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Appendix E – Estuary Property Tables: Example Formats 
 

Tidal levels (variables and definitions can be adjusted to suit) 

 

with DSproperties table: 

 

 

River Discharge (variables and definitions can be adjusted to suit) 

 

 

with DSproperties table: 
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Classification (variables and definitions can be adjusted to suit) 

 

 

with DSproperties table: 
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Appendix F – Archive File Format 
Estuary datasets can be saved to an ASCII file for archiving purposes (see Section 3.5.2). The file can 

be reloaded using Setup>Import Spatial Data >Load archive file (see Section 3.4.2).  

 

[Add details of repository] 


